Join the 80,000 other DTN customers who enjoy the fastest, most reliable data available. There is no better value than DTN!

(Move your cursor to this area to pause scrolling)




"I will tell others who want to go into trading that DTN ProphetX is an invaluable tool, I don't think anyone can trade without it..." - Comment from Luther
"Interactive Brokers tick data was inconsistent, so I have switched to using DTN exclusively. It is great to no longer have to worry about my datafeed all day long." - Comment from Philippe
"I used to have *******, but they are way more money for the same thing. I have had no probs with data from DTN since switching over." - Comment from Public Forum Post
"I am very pleased with the DTNIQ system for quotes and news." - Comment from Larry
"I just wanted to let you know how fast and easy I found it to integrate IQFeed into our existing Java code using your JNI client. In my experience, such things almost never go so smoothly - great job!" - Comment from Nate
"I'm satisfied with IQFeed. It's the most reliable and fastest quote feed I have ever used. Although I'm a resident in China, it's still very fast!" - Comment from Xiaofei
"Its working FABULOUSLY for me!! Holy cow...there has been so much I've been missing lately, and with this feed and Linnsoft software...I'm in the game now." - Comment from Chris R.
"My broker in Davenport suggested I give you a try as he uses your service and says its the best." - Comment from Bill via RT Chat
"I am very happy I changed. I love the product, but more so I am thrilled with Tech Support. You are knowledgeable, polite, pleasant and professional." - Comment from Pat
"Everything is working great with the API. I love it." - Comment from Calvin
Home  Search  Register  Login  Recent Posts

Information on DTN's Industries:
DTN Oil & Gas | DTN Trading | DTN Agriculture | DTN Weather
Follow DTNMarkets on Twitter
DTN.IQ/IQFeed on Twitter
DTN News and Analysis on Twitter
»Forums Index »IQFeed Developer »IQFeed Developer Support »Getting a "Connect failed. WSAGetLastError = 10049"
Author Topic: Getting a "Connect failed. WSAGetLastError = 10049" (4 messages, Page 1 of 1)

simon33
-Interested User-
Posts: 28
Joined: Apr 9, 2005


Posted: Sep 9, 2008 11:44 PM          Msg. 1 of 4
I have IQFeed on two machines. One connects and works perfectly. The other throws this error in the logs. "Connect failed. WSAGetLastError = 10049". I have compared the registery and the entries are the same. One thing I did see differently is that when I connect on the good machine, its on port 60020, on the bad machine its port 5002.

Here is more of the log:
FROM CLIENT (ADMIN)=2008-09-09 23:37:09: REGISTER_CLIENT_APP1 IQFEED_DEMO 1.0 0.11111111
TO CLIENT (ADMIN)=2008-09-09 23:37:09: 1
STATUS (LOOKUP)=2008-09-09 23:37:10: SOCKET ACCEPTED
FROM CLIENT (LOOKUP)=2008-09-09 23:37:10: HD,SPX.XO,600
IQConnect (CHistoryLookup::SendDayRequest)=2008-09-09 23:37:10: Connect failed. WSAGetLastError = 10049
TO CLIENT (LOOKUP)=2008-09-09 23:37:10: !ERROR! Could not connect to History socket.

JDonovan
-Interested User-
Posts: 24
Joined: Feb 11, 2007


Posted: Sep 10, 2008 07:58 AM          Msg. 2 of 4
10049 error indicates that either the IP address (an attempt to bind to an address that is not valid for the local machine) or the Port number is bad (port is not valid for a remote machine). Try modifying the IP/Port settings on the bad machine to match those on the good machine.

- Jeff

simon33
-Interested User-
Posts: 28
Joined: Apr 9, 2005


Posted: Sep 10, 2008 09:51 AM          Msg. 3 of 4
I checked the registry and all entries on both machines are the same with one exception: there is a key that exists on the good machine called showIDDMOTD=0 that is not in the other registry. Does this matter? Also, I looked in the event viewer on the machine and didn't see any events for 'applications'

If you didn't mean the registry settings, can you explain more about modifying the IP/Port settings. I'm rather technical (I'm a programmer) so you don't have to be exhaustive.

Thanks in advance.

DTN_Steve_S
-DTN Guru-
Posts: 2088
Joined: Nov 21, 2005


Posted: Sep 10, 2008 10:05 AM          Msg. 4 of 4
Hello simon33, it sounds to me like something is blocking the connection to the server. Are you behind a firewall or router? Do you have firewall software on the machine? If so, try configuring the firewall explicitly allow connections to the following ip addresses on port 5050 and 60050.

66.112.156.210 - 214
66.112.148.210 - 214
 

 

Time: Wed April 1, 2020 12:25 PM CFBB v1.2.0 16 ms.
© AderSoftware 2002-2003