Join the 80,000 other DTN customers who enjoy the fastest, most reliable data available. There is no better value than DTN!

(Move your cursor to this area to pause scrolling)




"I was with ******* for 4 years at $230 a month, this is a huge savings for me, GOD BLESS YOU PEOPLE," - Comment from T.S. via Email
"This is an excellent value, the system is generous (allowing for 500 stocks) and stable (and really is tick-by-tick), and the support is fantastic." - Comment from Shirin via Email
"As a past ******* customer(and not a happy one), IQ Feed by DTN is a much better and cheaper product with great customer support. I have had no problems at all since switching over." - Comment from Public Forum
"You are either overstaffed or people just don't have problems with your feed because customer support always answers the phone quickly." - Comment from Jay via Email
"I just wanted to let u know that your data feed/service is by far the best!!! Your unfiltered tick data is excellent for reading order flow and none of your competitors delivers this quality of data!" - Comment from Peter via Email
"I like you guys better than *******...much more stable and a whole lot fewer issues." - Comment from Philip
"Previously I was using *******. IQFeed is WAY more economical, and for my charting needs is just as good, if not better." - Comment from Public Forum Post
"Boy, probably spent a thousand hours trying to get ******* API to work right. And now two hours to have something running with IQFeed. Hmmm, guess I was pretty stupid to fight rather than switch all this time. And have gotten more customer service from you guys already than total from them… in five years." - Comment from Jim
"If you are serious about your trading I would not rely on IB data for serious daytrading. Took me a while to justify the cost of IQ Feed and in the end, it's just a 2 point stop on ES. Better safe than sorry" - Comment from Public Forum
"I'm very glad I switched to IQFeed. It's working perfectly with no lag, even during fast market conditions." - Comment from Andy via Email
Home  Search  Register  Login  Blogs Recent Posts

Information on Various DTN Products:
DTN IQFeed | DTN ProphetX | DTN Ag | NxCore
Follow DTN_IQFeed on Twitter
DTN.IQ/IQFeed on Twitter
DTN News and Analysis on Twitter
Viewing User Profile for: jrodrigo
About Contact
Joined: Apr 25, 2015 08:51 AM
Last Post: Feb 1, 2016 02:02 PM
Last Visit: Feb 1, 2016 02:02 PM
Website:  
Location:
Occupation:
Interests:
Email: jrodrigo@linux.com
AIM:
ICQ:
MSN IM:
Yahoo IM:
Post Statistics
jrodrigo has contributed to 8 posts out of 18071 total posts (0.04%) in 883 days (0.01 posts per day).

20 Most recent posts:

I'm starting to think that this comes from a long running wineserver...
I cannot force the dumps under a fresh wineserver.

I will restart a fresh wineserver with iqconnect each time and monitor this dumps for some hours/days,
we'll see if it is a wineserver issue.


The only files that I have under Docs are:

Docs/
Docs/res
Docs/res/style.css
Docs/res/image003.jpg
Docs/DDE.html
Docs/DDE.htm


Keep in mind that this crash is happening launching and closing iqconnect.exe, it is not a crash on operation. Could be cleanup or initializing issues.

Should I activate something on the iqconnect?
BTW I have totally restricted the wine debugger, so no crash notifier popup comes up nor the debugger kicks in, it justs crashes;
in this way I can get to restart iqconnect daemon style if a crash happens during operation.


Thanks Tim...

Well after starting and stopping iqconnect.exe beta for a good number of times during a 12 hour period I have some not so random crashes.

It seems to always follow a similar path through _XlcDestroyLocaleDataBase (some times RtlRaiseException is on the stack too):

Backtrace:
=>0 0xffffe430 __kernel_vsyscall+0x10() in [vdso].so (0x0152b7f8)
1 0xf73e7f47 gsignal+0x46() in libc.so.6 (0x0152b7f8)
2 0xf73e9616 abort+0x155() in libc.so.6 (0x0152b7f8)
3 0xf7425e72 in libc.so.6 (+0x6be71) (0x0152b7f8)
4 0xf742ba5a in libc.so.6 (+0x71a59) (0x7d9df1e8)
5 0xf742c6a8 in libc.so.6 (+0x726a7) (0x7d9df1e8)
6 0x7de700d4 _XlcDestroyLocaleDataBase+0x83() in libx11.so.6 (0x7d9be9c0)
7 0x7de74cb0 in libx11.so.6 (+0x4ecaf) (0x7dd10008)
8 0x7de7c4b6 _XCloseLC+0x75() in libx11.so.6 (0x7dd10008)
9 0x7de7c500 _XlcCurrentLC+0x2f() in libx11.so.6 (0x7dd10008)
10 0x7de752ed _Xlcmbstowcs+0xdc() in libx11.so.6 (0x7dd10008)
11 0x7de753d3 _Xmbstowcs+0x32() in libx11.so.6 (0x7dd10008)
12 0x7de8a86e in libx11.so.6 (+0x6486d) (0x7dd10008)
13 0x7de889c6 _XimLocalOpenIM+0x3f5() in libx11.so.6 (0x7da06360)
14 0x7de86e57 _XimOpenIM+0xf6() in libx11.so.6 (0x7da06360)
15 0x7de6c837 XOpenIM+0x46() in libx11.so.6 (0x0152dff8)
16 0x7dff0247 in winex11 (+0x50246) (0x0152dff8)
17 0x7dff1461 in winex11 (+0x51460) (0x0152e028)
18 0x7dfed783 in winex11 (+0x4d782) (0x0152e0e8)
19 0x7dfe61e1 X11DRV_WindowPosChanging+0x320() in winex11 (0x0152e178)
20 0x7eb6105f in user32 (+0xa105e) (0x0152e2c8)
21 0x7eb5cab9 in user32 (+0x9cab8) (0x0152e488)
22 0x7eb5642f CreateWindowExA+0x18e() in user32 (0x0152e718)
23 0x1023255c in mfc110 (+0x23255b) (0x0152e784)
24 0x1022d058 in mfc110 (+0x22d057) (0x0152e7f0)
25 0x1021b05a in mfc110 (+0x21b059) (0x0152e848)
26 0x1021b2f8 in mfc110 (+0x21b2f7) (0x0152e860)
27 0x1021a9dc in mfc110 (+0x21a9db) (0x0152e87c)
28 0x0040a8fd in iqconnect (+0xa8fc) (0x004acc34)
29 0x00613c98 (0x00613cc0)
0xffffe430 __kernel_vsyscall+0x10 in [vdso].so: popl %ebp


Could be a wine issue or maybe something going unhandled it is hard to tell. I leave you a log file with multiple occurences.

By the way I'm starting wine in X11 synchronous mode:

WINEDEBUG=-all,+synchronous


wine-1.9.0-36-g43197e6


Thanks Tim...

I continue to run the beta version and I can confirm that the the connection dialog pops up some times
and we are back to the 'procedural CONNECT impossibility' bug, human action is required (ie: click on the connect button).

I've run some more tests with the Diagnostics tool.
First of all, running the full test suite the application crashes.
I've read on the forum that this is due to the COM interfacing that is going to be removed.

There is some strange behaviour when launching the Diagnostic's traceroute.
I have activated the raw sockets capability for wine, so the Diagnostic's ping test works ok.
But the traceroute test reports Error:11010 (+very long timeout) for all the intermediate hops,
only the last hop returns the timing info.

Tracerouting the same boxes with the native Linux traceroute tool yields a lot more information,
the native tool manages to get timing info for some of the first hops (and some times the last one).

If this tracerouting capability is used by the iqconnect.exe application itself this behaviour could be bad.

In addition I would like to know if you are planning any more beta releases (maybe fixing the CONNECT issue),
because this beta seems to work better under wine.

The random crashes on iqconnect.exe start and shutdown under wine seem to have disappeared.
I knew that those crashes were related to the wine - iqconnect.exe interaction and it is nice that they are gone.

I would like to continue using the beta on a daily basis but the CONNECT problem impedes me to do so.
I have to install different iqconnect versions back and forth.

Thanks again Tim.


Having a native Linux version of iqconnect in console mode would be very nice.
Only the bare bones, maybe a static 64 bits release.

Thanks.

DTNIQ Client Software Wish List » iqconnect.exe & iqconnect_console.exe Jan 28, 2016 04:51 PM (Total replies: 10)

That could be very nice indeed.


I've run some tests with the beta 5.2.0.6 and it does not connect after issuing:

S,CONNECT

It simply does nothing, if I click the connect button it connects OK.

Under the 5.1.3.1 version it works as expected, I issue AUTOCONNECT OFF and then CONNECT and it works, no problem.

The beta 5.2.0.6 seems to reconnect when I issue CONNECT after a network loss.
It is only the first time after launching the client that CONNECT does not work???

I'm requesting the 5.1 protocol by the way. Here is the the input from the client:

S,CURRENT PROTOCOL,5.1,\r\n
S,REGISTER CLIENT APP COMPLETED,\n
S,CURRENT LOGINID,xxxxxxx,\n
S,CURRENT PASSWORD,xxxxxxx,\n
S,LOGIN INFO SAVED,\n
S,AUTOCONNECT OFF,\n
S,STATS,,,0,0,1,1,0,0,,,Not Connected,5.1.3.1,xxxx,0,0,,0.15,0.0,,\n
S,STATS,,,0,0,1,2,0,0,,,Not Connected,5.1.3.1,xxxx,0,0,,0.22,0.22,,\n
S,STATS,,,500,0,1,0,0,0,,,Not Connected,5.1.3.1,xxxx,0,0,,0.28,0.14,,\n
[...]

Issuing multiple CONNECT and never connects.

Using wine under Linux:

wine-1.9.0-36-g43197e6

Edited by jrodrigo on Jan 28, 2016 at 04:40 PM

IQFeed Developer Support » 5.1.2.5 iqconnect failing under Wine Apr 25, 2015 09:04 AM (Total replies: 4)

The 5.1.2.5 version hangs while logging on "Retrieving IP information" under wine.

It was a temporary problem (from time to time), but today 25/04/2015 at 9:30 EST
it has become constant, it is impossible to get logged so I have downgraded to
the 5.1.1.3 stable version.

The stable 5.1.1.3 did work as expected, I have not encountered this problem or
any other with this version.

I have attached the captured window with the client stucked while logging.


Time: Sat September 23, 2017 2:28 AM CFBB v1.2.0 16 ms.
© AderSoftware 2002-2003