Join the 80,000 other DTN customers who enjoy the fastest, most reliable data available. There is no better value than DTN!

(Move your cursor to this area to pause scrolling)




"The service is great, I see a noticeable improvement in my volume profiles over [broker]'s data feed" - Comment from Larry
"I'm very glad I switched to IQFeed. It's working perfectly with no lag, even during fast market conditions." - Comment from Andy via Email
"Everything is working great ! Very impressive client. The news refreshes better and is more pertinent than the ******* feed I paid $ 100/month for. I Also like the charts a lot." - Comment from Leon
"I am a hedge fund manager here. It’s funny, I have a Bloomberg terminal and a Bridge feed, but I still like having my DTN feed!" - Comment from Feras
"If you are serious about your trading I would not rely on IB data for serious daytrading. Took me a while to justify the cost of IQ Feed and in the end, it's just a 2 point stop on ES. Better safe than sorry" - Comment from Public Forum
"I'm satisfied with IQFeed. It's the most reliable and fastest quote feed I have ever used. Although I'm a resident in China, it's still very fast!" - Comment from Xiaofei
"I would just like to say that IQFeed version 4 is running very well and I am very happy with its performance. I would also like to extend a big thanks for the fast and efficient help that I always receive. My questions and concerns are always addressed promptly. Way to go!" - Comment from Josh in CO.
"With HUGE volume on AAPL and RIMM for 2 days, everyone in a trading room was whining about freezes, crashes and lag with *******, RealTick, TS and Cyber. InvestorRT with IQFeed was rock solid. I mean SOLID!" - Comment from Public IRC Chat
"Can I get another account from you? I am tired of ******* going down so often" - Comment from George
"You have an excellent feed. Very few spikes for Spot Forex." - Comment from Public Forum Post
Home  Search  Register  Login  Recent Posts

Information on DTN's Industries:
DTN Oil & Gas | DTN Trading | DTN Agriculture | DTN Weather
Follow DTNMarkets on Twitter
DTN.IQ/IQFeed on Twitter
DTN News and Analysis on Twitter
»Forums Index »IQFeed Developer »IQFeed Developer Support »protocol 6.1 problem
Author Topic: protocol 6.1 problem (6 messages, Page 1 of 1)

HenriM
-Interested User-
Posts: 3
Joined: Sep 7, 2019


Posted: Sep 7, 2019 08:32 PM          Msg. 1 of 6
I'm getting response
"S,CURRENT PROTOCOL,6.0," on request S,SET PROTOCOL,6.0
and response "E,6.1 is not a valid protocol.," on request S,SET PROTOCOL,6.1
I'm using same code and only change 6.0 to 6.1 in it.
6.0 protocol works fine, but it doesn't recognize new field "Most Recent Trade Aggressor"
Any ideas?
Thank you

Henri

altmany
-Interested User-
Posts: 45
Joined: Jul 30, 2018

IQML - IQFeed-MATLAB connector


Posted: Sep 8, 2019 01:58 AM          Msg. 2 of 6
Most likely you are still using the 6.0 client - download and install the 6.1 client from http://www.iqfeed.net/index.cfm?displayaction=support§ion=download

Yair Altman
IQML - IQFeed-MATLAB connector
https://UndocumentedMatlab.com/IQML

I am not a DTN employee; my post reflects my personal opinion

HenriM
-Interested User-
Posts: 3
Joined: Sep 7, 2019


Posted: Sep 8, 2019 11:11 AM          Msg. 3 of 6
Thank you Yair,
I should have mentioned that before I posted this problem I have downloaded client 6.1.0.20 from September 4th but I always just download and install latest version of client without uninstalling anything. Hopefully that is the correct procedure.
I have just also checked VB value of System.Reflection.Assembly.GetExecutingAssembly().GetName().Version.ToString()
It retrieves value 6.1.0.0, which hopefully also indicates that protocol 6.1 has been installed correctly.
Thank you

Henri

DTN_Gary_Stephen
-Interested User-
Posts: 52
Joined: Jul 3, 2019


Posted: Sep 13, 2019 08:52 AM          Msg. 4 of 6
Henri,

Yair is correct - if you're getting the message "E,6.1 is not a valid protocol", the problem is most likely that you're still using client software version 6.0. We just released 6.1.0.20 last week; it can be downloaded from the usual download page, http://www.iqfeed.net/index.cfm?displayaction=support§ion=download

Henri, my logs show that you're still connecting using client software version 6.0.1.1. That would explain why you're getting this error message. Check your install, update to 6.1.0.20 if necessary, and try again. There are two ways you can determine the version number you have currently:

1. If you are not connected, launch the Diagnostics app. Click Test button on the IQConnect tab. The second line of the output will say "Loading IQFeed with (IQFeed Diagnostics, 6.x.x.x)". That's the version number.

2. If you are connected, right-click the IQFeed icon in the system tray, and select Feed Stats. "IQFeed Version" will be one of the pieces of information, on the right hand side.

Please feel free to contact me directly if I can help!

Sincerely,
Gary Stephen
DTN IQFeed Implementation Support Specialist

HenriM
-Interested User-
Posts: 3
Joined: Sep 7, 2019


Posted: Sep 13, 2019 10:20 AM          Msg. 5 of 6
Thank you Gary,
problem solved:

I was downloading
IQFeed Client 6.1.0.20 September 4th, 2019 Download
from page
http://www.iqfeed.net/dev/api.cfm

when I downloaded
IQFeed (Datafeed) 6.1.0.20 September 4th, 2019 Download
http://www.iqfeed.net/index.cfm?displayaction=support§ion=download
my problem went away

Henri

DTN_Gary_Stephen
-Interested User-
Posts: 52
Joined: Jul 3, 2019


Posted: Sep 13, 2019 10:21 AM          Msg. 6 of 6
OK, that makes sense. Let me know if you have any further questions or issues!

Sincerely,
Gary Stephen
DTN IQFeed Implementation Support Specialist
 

 

Time: Wed April 8, 2020 10:44 AM CFBB v1.2.0 16 ms.
© AderSoftware 2002-2003