Join the 80,000 other DTN customers who enjoy the fastest, most reliable data available. There is no better value than DTN!

(Move your cursor to this area to pause scrolling)

"The people at Nirvana have very nice things to say about your company and I can see why! Price and service is a potent combination." - Comment from Ed
"I am very pleased with the DTNIQ system for quotes and news." - Comment from Larry
"I cannot believe what a difference it makes trading with ProphetX!" - Comment from Bruce in Los Angeles
"I would just like to say that IQFeed version 4 is running very well and I am very happy with its performance. I would also like to extend a big thanks for the fast and efficient help that I always receive. My questions and concerns are always addressed promptly. Way to go!" - Comment from Josh in CO.
"Previously I was using *******. IQFeed is WAY more economical, and for my charting needs is just as good, if not better." - Comment from Public Forum Post
"I was on the phone with a friend who uses CQG and right after the Fed announcement, CQG was as much as 30 seconds behind DTN.IQ. Some quotes were off by as much as 15-18 cents. Your feed never missed a beat." - Comment from Roger
"There is no doubt that IQFeed is the best data provider. I am very satisfied with your services. And IQFeed is the only one that I would recommend to my friends. Now, most of them are using your product in China." - Comment from Zhezhe
"Thanks for all of your help. Great customer service deserves to be recognized which one the reasons I've been a customer of DTN for over 10 years!" - Comment from Stuart
"Thanks for the great product and support. During this week of high volume trading, my QuoteTracker + IQ Feed setup never missed a beat. Also, thanks for your swiftness in responding to data issues. I was on ******* for a few years before I made the switch over early this year, and wish I had done it a long time ago." - Comment from Ken
"I just wanted to say how happy I am with your service. I was able to download the API docs last week and I was able to replicate Interactive Brokers historical bar queries and realtime bar queries over the weekend. That was about one of the fastest integrations that I've ever done and it works perfectly!!!!" - Comment from Jason via Email
Home  Search  Register  Login  Recent Posts

Information on DTN's Industries:
DTN Oil & Gas | DTN Trading | DTN Agriculture | DTN Weather
Follow DTNMarkets on Twitter
DTN.IQ/IQFeed on Twitter
DTN News and Analysis on Twitter
Viewing User Profile for: programmer
About Contact
Joined: Feb 3, 2010 12:14 PM
Last Post: Mar 21, 2019 08:12 AM
Last Visit: Dec 30, 2020 10:23 AM
Yahoo IM:
Post Statistics
programmer has contributed to 35 posts out of 20641 total posts (0.17%) in 4,528 days (0.01 posts per day).

20 Most recent posts:
Data and Content Support » As of 3/14 some market symbols are "invalid" Mar 21, 2019 08:12 AM (Total replies: 6)

After digging in to it, that error is actually one of my internal errors and kind of generic (ie. it can be caused by a number of things). I'm not sure what the IQ client is returning but I am running the latest now

I'm still investigating this. I have a lot of things I need to upgrade including the OS. I managed to get some history pulls yesterday without errors so it obviously CAN work. I'm thinking the problem is probably on my side. Though I'm not sure why this started all of a sudden. Anyway, I'm going to rework some of my code making that error less generic so I can see was is going on in case this happens again.

Thanks for the help!

Data and Content Support » As of 3/14 some market symbols are "invalid" Mar 20, 2019 04:09 PM (Total replies: 6)

Thanks for checking. Seems to be working fine now during the day but I just updated from to so I'll see how that goes tonight too.

Looking at version I see: Added support for 64bit (8+ decimals) precision prices in streaming (Level 1) data and History data (as soon as the history servers support rolls out).

Any chance the history servers updated to this new 64bit precision on March 14?

Just trying to figure out what happened. I'll keep testing to make sure the problem is not on my side.

Data and Content Support » As of 3/14 some market symbols are "invalid" Mar 20, 2019 09:09 AM (Total replies: 6)

On March 14 all of a sudden I'm getting a lot of "Invalid symbol" errors. For example pulling history for "APPS" returns invalid symbol even though it's not. I'm not sure if they're all NASDAQ but many of them seem to be.

Maybe I need to update my IQFeed client because I think I'm out of date or maybe my machine has been corrupted.

I'm looking in to the issue on my side but figured I would post to ask if something changed.

Data and Content Support » Market symbols zip file seems to be corrupted Jun 6, 2017 08:13 AM (Total replies: 2)

Looks good. I tried at about 6:45 AM and it was still corrupt which is why I posted but I assume the zip rebuild must be some time later than that. Anyway, it's fixed now. Thanks!

Data and Content Support » Market symbols zip file seems to be corrupted Jun 6, 2017 05:46 AM (Total replies: 2)

It seems like as of yesterday the symbols archive has been corrupted (ie. invalid zip file). I was hoping it would get fixed when it was rebuilt for today but that doesn't appear to be the case.

I'm talking about the list here:

Data and Content Support » Is the symbol list no longer maintained? Mar 27, 2016 08:52 AM (Total replies: 2)

I'm talking about the list here:

It used to be updated every day but for months it has only been sporadically updated. It currently hasn't been updated since March 17.

Is there a better way to get this list?

Data and Content Support » IB exchange waiver no longer works Mar 11, 2016 10:06 PM (Total replies: 1)

*** deleted original message ***

Never mind. I was using IQLink to start IQFeed and apparently you need to use whatever "validated" software (from the list) to start IQFeed.

I think I made a note about this a long time ago but since lost it. I'll make another again so I don't forget.
Edited by programmer on Mar 12, 2016 at 12:11 AM

IQFeed Developer Support » out of memory in sockets in v May 29, 2013 08:06 AM (Total replies: 20)

Just thought I would note that it's easy to recreate the memory leak simply by connecting to any iqfeed socket then disconnect (no command need to be executed). Do it several thousand times and watch the memory usage grow.
Edited by programmer on May 29, 2013 at 08:07 AM

IQFeed Developer Support » out of memory in sockets in v May 28, 2013 01:51 PM (Total replies: 20)

Quote: The one theme I've seen between all of your scenarios is that you are making multiple connections to the feed (not simply maintaining a single connection and making multiple requests). Is this accurate?

That is true for me. It seems to leak around 200 bytes per connection. Not so much by itself but over a long enough time the iqconnect.exe process causes the machine to run out of RAM and I get the out of memory error.
Edited by programmer on May 28, 2013 at 01:59 PM

IQFeed Developer Support » out of memory in sockets in v May 25, 2013 01:33 PM (Total replies: 20)

I'm getting this error too and I'm not making lots of simultaneous socket connections. It seems that over time iqconnect.exe uses more and more memory until it consumes all memory on the machine. If you make a lot of connections for example to pull historical data (NOT simultaneous connections; just sequential) it will use up memory faster.

I believe there is some sort of memory leak in the version of iqconnect.exe.

I think I may have it working. It could be because my filesystem was corrupted. I tried again on a fresh install and now it seems to survive the reboot.

However, it does not seem to work unless you install IQ 4.7 at least once. I'm guessing because a dll (IQ32.dll?) or other components needs to be registered or configured and just copying over IQ32.dll is not enough on a clean new system that never had 4.7 installed.

But like I said, it seems to work right now. Sorry for the noise. Thanks!

DTN.IQ Client Software Support » IQFeed is now spyware? Dec 10, 2012 08:22 AM (Total replies: 1)

What are these "usage statistics" reported with the newer versions of IQFeed?

I apologize if I seem alarmist but you have to understand that I don't like anything that could possibly affect my trading and I definitely don't like software that spies on my system. What is it reporting exactly and why? Can I disable it? "Anonymous" reporting is not an answer because an IP address is usually enough information to connect a user to "statistics".


I'm finding that it still doesn't work. I tried a fresh install of IQFeed 4.9 and QT, copied the IQ32.dll over to the IQFeed install directory. I then start QuoteTracker and it immediately sends me to their "How to install IQFeed" page. QuoteTracker is not able to start or connect to IQFeed.

I then install IQFeed 4.7 and everything works normally. Then I re-installed IQ 4.9 and now 4.9 works with QuoteTracker. Then I reboot and now QuoteTracker no longer works with IQFeed 4.9

This doesn't seem to work very well and is the reason I have been avoiding anything newer than IQFeed 4.7.

Data and Content Support » Tick timestamps out of order Jul 31, 2011 09:34 PM (Total replies: 4)

OK thanks. If that's the way it would show up in the live stream then I'll just leave it as is.

Data and Content Support » Tick timestamps out of order Jul 31, 2011 09:24 PM (Total replies: 4)

I was looking through some of the raw data in the platform I use and I noticed that sometimes (fairly rarely) that some of my backfill data has ticks with timestamps that are out of order. For example:

2011-07-11 15:58:34,1315.00,4573299 <-- tick id
2011-07-11 15:58:34,1315.00,4573298
2011-07-11 15:58:33,1315.00,4573297
2011-07-11 15:58:33,1315.00,4573296
2011-07-11 15:58:34,1315.00,4573295
2011-07-11 15:58:33,1315.00,4573294
2011-07-11 15:58:33,1315.00,4573293

You can see the third tick from the bottom has a timestamp that is out of order. The tick ID seems to suggest that the timestamp is incorrect (either that or the tick id is incorrect). I refreshed the data and it stays the same so I believe it's stored on the server this way. It doesn't happen too often but it always happens the same way with the timestamp slightly off but the tick id is in order.

Even though it seems to not happen often, I'm a bit fanatical about having accurate data so I'm wondering if I should manually correct the timestamp or move the ticks to their correct position in the stream?
Edited by programmer on Jul 31, 2011 at 09:25 PM

Data and Content Support » Backfill times slowed considerably recently? Jul 31, 2011 09:11 PM (Total replies: 2)

Yes I have been noticing this as well. It takes more than twice as long as it used to which seems to match up with what you are seeing.

Data and Content Support » What is going on in @ES#? Corrupt data Aug 18, 2010 11:46 AM (Total replies: 4)

I think it's just a bug in the platform that was introduced with recent updates. I was able to recreate the problem just with last weeks data and it seemed somewhat random.

Sorry for the noise but I think everything is working fine (or will be once they fix it ).

Data and Content Support » What is going on in @ES#? Corrupt data Aug 18, 2010 11:24 AM (Total replies: 4)

I suppose it could be a bug in the platform. It seems like mostly older dates (a week or two ago) when pulled from historical data.

I'll have to wait till the end of the day so I can pull ticks that old, then I'll try refreshing from a fresh install of the platform and see how that goes. I'm just requesting one symbol at a time. I'm not sure what request the platform uses but I can find out.

I have never seen this before so that's why I was thinking it might be the data itself but now I don't know.
Edited by programmer on Aug 18, 2010 at 11:26 AM

Data and Content Support » What is going on in @ES#? Corrupt data Aug 18, 2010 10:46 AM (Total replies: 4)

I'm looking at tick data on the @ES# instrument and I'm seeing all sorts of bad data. It may not be just that symbol, it's the only one I have looked at.

Some ticks have dates with bad years like 22010-MM-DD, 202010-MM-DD, 2012010-MM-DD, and 20102010-MM-DD.

I'm also seeing some ticks with an incorrect number of fields like:
2010-08-04 10:08:12,1122.50,1,519776,513811,1123.75,1124.00,11823938,0,0

That tick has an extra field that shouldn't be there (looks like the volume got duplicated or something).

Data and Content Support » DTN calculated market stats Jun 22, 2010 11:35 AM (Total replies: 4)

OK thanks, that link has a lot more useful information in it!

The only thing missing as far as I'm concerned is a comprehensive explanation of "dollar volume." (ie. those symbols that have "$ VOL" in the description)

Time: Mon June 27, 2022 3:24 PM CFBB v1.2.0 16 ms.
© AderSoftware 2002-2003